Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.1.8

Bug #4047 Parse error: parse error in /usr/share/pear/Auth/HTTP.php on line 247
Submitted: 2005-04-04 01:17 UTC Modified: 2005-04-04 07:50 UTC
From: pear at sapphire dot no Assigned: hirokawa
Status: Closed Package: Auth_HTTP
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-04-04 01:17 UTC] pear at sapphire dot no
Description: ------------ After upgrading from Auth_HTTP 2.1.4 to 2.1.5, all applications using Auth_HTTP fails with the following error: Parse error: parse error in /usr/share/pear/Auth/HTTP.php on line 247 The reason for this error is a missing ")" on line 247. This patch fixes this error: --- HTTP.php.orig 2005-04-04 08:04:52.000000000 +0200 +++ HTTP.php 2005-04-04 08:04:11.000000000 +0200 @@ -244,7 +244,7 @@ $this->password = ''; $this->digest_header = null; - if (!empty($this->server['PHP_AUTH_DIGEST']) { + if (!empty($this->server['PHP_AUTH_DIGEST'])) { $this->digest_header = substr($this->server['PHP_AUTH_DIGEST'], strpos($this->server['PHP_AUTH_DIGEST'],' ')+1); } else {

Comments

 [2005-04-04 07:50 UTC] hirokawa
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.