Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.2

Bug #3902 package is not ready to work with primaryCol not int
Submitted: 2005-03-21 11:36 UTC Modified: 2005-03-25 19:09 UTC
From: marcin dot krzyzanowski at gmail dot com Assigned: quipo
Status: Closed Package: DB_QueryTool
PHP Version: 5.0.2 OS: MacOS
Roadmaps: (Not assigned)    
Subscription  


 [2005-03-21 11:36 UTC] marcin dot krzyzanowski at gmail dot com
Description: ------------ DB_QueryTool is not ready to work with $primaryCol other than "INT" because of brackets. Reproduce code: --------------- $primaryCol = "username"; ....... $data = array( 'username' => "'aaa'", 'password' => "bbb" ); $authTable->update($data); Expected result: ---------------- SELECT auth.username AS "username",auth.password AS "password" FROM auth WHERE auth.username='aaa' UPDATE auth SET username='aaa',password='bbb)' WHERE username='aaa' similar with ->add then it produce "WHERE username=aaa" instead "WHERE username='aaa'" Actual result: -------------- SELECT auth.username AS "username",auth.password AS "password" FROM auth WHERE auth.username='aaa' UPDATE auth SET username='\'aaa\'',password='bbb)' WHERE username='aaa'

Comments

 [2005-03-25 19:09 UTC] quipo
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.