Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.4.0

Bug #3897 Typo in outputRightsConstants()
Submitted: 2005-03-21 08:18 UTC Modified: 2006-12-24 16:12 UTC
From: pasi at schnappshot dot de Assigned: lsmith
Status: Closed Package: LiveUser_Admin
PHP Version: 5.0.3 OS: Ubuntu Linux 4.?
Roadmaps: (Not assigned)    
Subscription  


 [2005-03-21 08:18 UTC] pasi at schnappshot dot de
Description: ------------ Version: CVS from 2005-03-21 File: LiveUser_Admin/Perm/Simple.php Function: outputRightsConstants() When limiting the constant-creation to a specific application and/or area, the query for fetching the right-ids results in an error. This is caused by a false definition of the filters. Reproduce code: --------------- Solution: The array key for filters is 'filters' and not 'filter'. line 817: - $opt['filter']['area_id'] = $options['area']; + $opt['filters']['area_id'] = $options['area']; line 821: - $opt['filter']['application_id'] = $options['application']; + $opt['filters']['application_id'] = $options['application'];

Comments

 [2005-03-21 08:23 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.