Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.2

Bug #3680 getOne throws error
Submitted: 2005-03-03 03:22 UTC Modified: 2005-03-04 18:28 UTC
From: rgu at era-it dot ch Assigned: danielc
Status: Closed Package: DB
PHP Version: 4.3.10 OS: Win XP
Roadmaps: (Not assigned)    
Subscription  


 [2005-03-03 03:22 UTC] rgu at era-it dot ch
Description: ------------ After Upgrade from DB 1.6.8 to 1.7.1 the getOne command throws an error back. No changes were made to the script or any config file. Reproduce code: --------------- // Execute query $selTestID = "SELECT max(\"test_id\") from search_table"; $sth = $dbh->getOne($selTestID); if (DB::isError($sth)) { die ($sth->getMessage()); } Expected result: ---------------- Correct row ID, f.e. ID_0001 Actual result: -------------- DB Error: syntax error

Comments

 [2005-03-03 09:18 UTC] danielc
Instead of getMessage(), please submit the output of getDebugInfo(). Which DBMS and version of it are you using?
 [2005-03-03 11:59 UTC] danielc
Fixed in new release (1.7.2)
 [2005-03-04 18:28 UTC] danielc
The modifyLimitQuery() optimizations for getOne() and getRow() have been removed from DB as of release 1.7.3 due to backwards compatibility issues.