Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.0

Bug #3657 php5 clone constant/token in all sources
Submitted: 2005-03-01 04:50 UTC Modified: 2005-03-14 08:38 UTC
From: techtonik Assigned: davey
Status: Closed Package: PHP_CompatInfo
PHP Version: 4.3.10 OS: W2K
Roadmaps: (Not assigned)    
Subscription  


 [2005-03-01 04:50 UTC] techtonik
Description: ------------ Running Cli.php utility on this file http://cvs.php.net/co.php/phpdoc/scripts/phpweb-entities.php.in?r=1.2 yields some php5 dependencies? Reproduce code: --------------- php.exe -f Cli.php -- --file=phpweb-entities.php.in --debug Expected result: ---------------- +---------+----------+-----------+ | Version | Function | Extension | +---------+----------+-----------+ | | | | +---------+----------+-----------+ Actual result: -------------- +------------------------+---------+------------+------------------+ | File | Version | Extensions | Constants/Tokens | +------------------------+---------+------------+------------------+ | phpweb-entities.php.in | 5.0.0 | | clone | +------------------------+---------+------------+------------------+ Debug: +---------+----------+-----------+ | Version | Function | Extension | +---------+----------+-----------+ | | | | +---------+----------+-----------+

Comments

 [2005-03-05 19:32 UTC] davey
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. I found the issue, though it was annoying. The constants T_IF in PHP4 and T_CLONE in PHP5 share the same value. Unfortunately, to fix this, I had to make PHP5 detection on PHP4 (only) a little less reliable (it won't find T_CLONE's at all any more). - Davey
 [2005-03-06 13:32 UTC] techtonik
Is it possible to correct this problem on Zend engine level? Seems like a conflict. I can only presume that changed value for T_CLONE will not lead to any problems. But if it's true - why not to fix it in PHP?
 [2005-03-06 18:26 UTC] davey
The reason for the constants such as T_CLONE and T_IF is so that the ZE can change the values for them without any repercussions. The issue with PHP_CompatInfo, is I specifically use the numbers so as not to cause any issues with PHP4 and the PHP5 only constants. I think that wanting the ability to find PHP5 code using PHP4 is ridiculous anyways, so I would mark that a Won't Fix. If you're developing PHP5 code, you're using PHP5 ;) - Davey
 [2005-03-09 10:50 UTC] techtonik
Still more bugs. Check this out. =) http://cvs.php.net/co.php/phpdoc/scripts/ shortened filepaths a bit, but the idea is that all these files run on 4.3.10 ... | /phpdoc/scripts/xml_proto.php | 5.0.0 | | final | | | | | __METHOD__ | | /phpdoc/scripts/process.php | 5.0.0 | | implements | | /phpdoc/scripts/orphan_notes.php | 5.0.0 | | abstract | | | | | throw | | /phpdoc/scripts/notes_stats.php | 5.0.0 | | abstract | | | | | final | ...
 [2005-03-14 08:38 UTC] davey
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. I'll be releasing 1.0.0 Stable shortly with the fix in it. See changelog for details. Thank you so much for finding this bug(s) :) - Davey