Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.9

Bug #3578 wrong quotable encoding
Submitted: 2005-02-24 09:50 UTC Modified: 2006-02-09 04:45 UTC
From: j dot drobiecki at mwi dot pl Assigned: cipri
Status: Bogus Package: Mail_Mime
PHP Version: Irrelevant OS: irrevelant
Roadmaps: (Not assigned)    
Subscription  


 [2005-02-24 09:50 UTC] j dot drobiecki at mwi dot pl
Description: ------------ For proper display of Subject header there should be no spaces beetwen two quotable encoded words in header. Reproduce code: --------------- pathc: Mail/mime.php:645: - $input[$hdr_name] = $hdr_value; + $input[$hdr_name] = preg_replace('/\?=( *)=\?' . $this->_build_params['head_charset'] . '\?Q\?/', '\1', $hdr_value); Expected result: ---------------- Subject: =?ISO-8859-2?Q?narz=EAdzie w=B3adzy?= Actual result: -------------- Subject: =?ISO-8859-2?Q?narz=EAdzie?= =?ISO-8859-2?Q?w=B3adzy?=

Comments

 [2005-02-24 10:33 UTC] dufuz
I'd say that this is a mail_mime bug not doc bug ;)
 [2005-09-08 06:54 UTC] norbert
The bug report and the provided patch is correct (tested recently by applying to my local copy).
 [2005-09-08 06:56 UTC] norbert
Before (WRONG): Subject: =?ISO-8859-2?Q?H=EDrlev?==?ISO-8859-2?Q?=E9l?= =?ISO-8859-2?Q?feliratkoz=E1s?= Rendered as Hirlevelfeliratkozas (with national accents) After (CORRECT): Subject: =?ISO-8859-2?Q?H=EDrlev=E9l feliratkoz=E1s?= Rendered as Hirlevel feliratkozas (with national accents)
 [2005-09-08 07:13 UTC] norbert
for the sake of clarity, this is function _encodeHeaders()
 [2006-02-09 04:45 UTC] cipri
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the existing bug instead. Thank you for your interest in PEAR. Duplicate of Bug #30