Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0

Bug #3368 Mobile/NonMobile.php dose not implement makeDisplay()
Submitted: 2005-02-03 03:00 UTC Modified: 2005-02-03 03:57 UTC
From: roux at dot-wired dot org Assigned: kuboa
Status: Closed Package: Net_UserAgent_Mobile
PHP Version: 4.3.10 OS: Debian
Roadmaps: (Not assigned)    
Subscription  


 [2005-02-03 03:00 UTC] roux at dot-wired dot org
Description: ------------ Mobile/NonMobile.php dose not implement makeDisplay(). So, non mobile UA detected (Mobile/NonMobile.php required), died by getDisplay() method calls, because of Mobile/Common.php 's makeDisplay() method. Accoding to its API document, this case should return PEAR error object. http://pear.php.net/package/Net_UserAgent_Mobile/docs/0.21.0/Net_UserAgent_Mobile/Net_UserAgent_Mobile_Common.html#methodgetDisplay Reproduce code: --------------- <?php require_once "Net/UserAgent/Mobile.php"; $obj = Net_UserAgent_Mobile::factory("Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"); $display = $obj->getDisplay(); var_dump($display); // Nothing occured because Died at Common.php ?>

Comments

 [2005-02-03 03:41 UTC] kubo at isite dot co dot jp
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Net_UserAgent_Mobile
 [2005-02-03 03:57 UTC] kubo at isite dot co dot jp
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.