Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.1

Bug #3355 buildPath generates Warnings (missing delimiter in preg_quote())
Submitted: 2005-02-02 02:33 UTC Modified: 2005-02-02 04:07 UTC
From: cmoehrke at netviser dot de Assigned: mike
Status: Closed Package: File
PHP Version: 5.0.3 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-02-02 02:33 UTC] cmoehrke at netviser dot de
Description: ------------ Using buildPath() results in a number of warnings, because the delimiter of the PCRE is a / which clashes with the directory separator. Reproduce code: --------------- require_once('File/Util.php'); $parts=array('a','b','c'); echo File_Util::buildPath($parts); Expected result: ---------------- a/b/c Actual result: -------------- Warning: preg_match() [function.preg-match]: Unknown modifier '+' in /usr/local/php/pear/File/Util.php on line 60 Warning: preg_match() [function.preg-match]: Unknown modifier '+' in /usr/local/php/pear/File/Util.php on line 60 Warning: preg_match() [function.preg-match]: Unknown modifier '+' in /usr/local/php/pear/File/Util.php on line 60 a/b/c

Comments

 [2005-02-02 04:07 UTC] mike
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.