Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.4

Bug #3247 set_time_limit() warning when safe_mode is on
Submitted: 2005-01-19 13:48 UTC Modified: 2005-01-20 10:33 UTC
From: herojoker at nexgo dot de Assigned: mike
Status: Closed Package: HTTP_Download
PHP Version: 4.3.10 OS: Gentoo/Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-01-19 13:48 UTC] herojoker at nexgo dot de
Description: ------------ Hi In the send method in Download.php on line 610 set_time_limit(0); is executed. But if safe_mode is on this is disabled and an error occures. Please check whether safe_mode is off and make the set_time_limit(0) call dependend on that. Reproduce code: --------------- Old code: set_time_limit(0); You could use this: if (!((bool) ini_get('safe_mode'))) { set_time_limit(0); } Expected result: ---------------- I hope that will help you, Hero Wanders

Comments

 [2005-01-20 03:22 UTC] mike
What's the error type? (NOTICE|WARNING|ERROR)
 [2005-01-20 04:19 UTC] herojoker at nexgo dot de
The error type is WARNING. I hope you will fix that :) Hero Wanders
 [2005-01-20 04:23 UTC] herojoker at nexgo dot de
There is another issue coming with that error. If the error is displayed the data to send (I send raw data, if it is important to know) is displayed in the browser. Perhaps that is because PHP automatically sends the standard header when an error message is displayed. Therefore the file cannot be sent correctly. You also could add a @ to the set_time_limit call, but I think my first solution is better. Thx, Hero Wanders
 [2005-01-20 10:33 UTC] mike
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Thanks.