Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.4.0

Bug #3245 $with in getGroups in LiveUser_Admin_Perm_Medium is used but not seted with par
Submitted: 2005-01-19 11:37 UTC Modified: 2005-05-06 06:27 UTC
From: fabio at bs2 dot com dot br Assigned: lsmith
Status: Closed Package: LiveUser_Admin
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2005-01-19 11:37 UTC] fabio at bs2 dot com dot br
Description: ------------ variable $with in function getGroups in LiveUser_Admin_Perm_Medium is used but is not set with an parameter because this the function dont return rigths of group

Comments

 [2005-01-19 11:42 UTC] dufuz
Would be nice if you told us for once what version of the admin class you're using, 0.1.0 or CVS ? Would help a lot.
 [2005-01-19 12:04 UTC] fabio at bs2 dot com dot br
 [2005-01-19 12:09 UTC] dufuz
aaight, thanks, we'll look into it, might tho been fixed already :)
 [2005-01-21 16:39 UTC] smith at backendmedia dot com
Seems like I wasnt in when I originally commented this bug a few days ago. Generally you are right. However I was never happy with the way we implemented the "with" handling. I have a cleaner implementation in my head that will use a property to store the possible "with" calls similar to how selectable_tables now work. I think this will have to wait until 0.3 however.
 [2005-05-06 06:27 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.