Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.5

Bug #3073 Calendar_Month_Weekdays, empty days at year change
Submitted: 2004-12-31 03:40 UTC Modified: 2005-10-20 04:16 UTC
From: phade at hot dot ee Assigned: quipo
Status: Closed Package: Calendar
PHP Version: 4.3.9 OS: Redhat 9
Roadmaps: (Not assigned)    
Subscription  


 [2004-12-31 03:40 UTC] phade at hot dot ee
Description: ------------ Unless I am missing something empty days (days that stay to the following month) at the end of the last month of the year are incorrect. They display month number that is out of range and also do not adjust the year. Reproduce code: --------------- require_once "Calendar/Month/Weekdays.php"; $myMonth = new Calendar_Month_Weekdays(2004,12); while($day = $myMonth->fetch()) { print_r($day); } Expected result: ---------------- print_r() output of the first empty day in the while loop should look like this calendar_day Object ( [cE] => calendar_engine_unixts Object ( ) [validator] => [year] => 2005 [month] => 1 [day] => 1 [hour] => 0 [minute] => 0 [second] => 0 [selected] => [children] => Array ( ) [first] => [last] => [empty] => 1 ) Actual result: -------------- print_r() output of the first empty day in the while loop looks like this: calendar_day Object ( [cE] => calendar_engine_unixts Object ( ) [validator] => [year] => 2004 [month] => 13 [day] => 1 [hour] => 0 [minute] => 0 [second] => 0 [selected] => [children] => Array ( ) [first] => [last] => [empty] => 1 )

Comments

 [2005-10-20 04:16 UTC] quipo
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.