Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.3

Bug #2876 German Umlauts destroy sheet references
Submitted: 2004-12-02 12:00 UTC Modified: 2005-11-07 19:24 UTC
From: bieniek at dotzilla dot de Assigned: xnoguer
Status: Closed Package: Spreadsheet_Excel_Writer
PHP Version: 4.3.9 OS: Win32/Linux
Roadmaps: (Not assigned)    
Subscription  


 [2004-12-02 12:00 UTC] bieniek at dotzilla dot de
Description: ------------ If You use german umlauts in sheetnames like Düsseldorf (ÖÄÜöäüß) the sheet reference is broken... with strange behaviour... although spaces are not working Reproduce code: --------------- $ypos=1; $worksheetname="Düsseldorf"; $worksheet->write($ypos,0,$worksheetname); $formula="='".$worksheetname."'!A1"; # not working $worksheet->writeFormula($ypos,1,$formula); $worksheetname="Essen 1"; $formula="='".$worksheetname."'!A1"; #not working $worksheet->writeFormula($ypos,2,$formula); $worksheetname="Essen"; $formula="='".$worksheetname."'!A1"; #working $worksheet->writeFormula($ypos,3,$formula); Expected result: ---------------- Field 1 0 Value= Düsseldorf Field 1 1 Value of ='Düsseldorf'!A1 Field 1 2 Value of ='Essen 1'!A1 Field 1 3 Value of ='Essen'!A1 Actual result: -------------- Field 1 0 Value= Düsseldorf Field 1 1 Value of some field in the current sheet Field 1 2 Value of straight error Field 1 3 Value of ='Essen'!A1

Comments

 [2005-11-07 19:24 UTC] xnoguer at php dot net
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. seems to be working for me now, but if you could test the cvs version I would really apreciate it. The fix requires php >= 4.1.0 in unix or php >= 4.2.3 on win.