Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.16.14

Bug #2491 LiveUser::(factory/singleton/init) $remember param does nothing
Submitted: 2004-10-11 02:19 UTC Modified: 2006-12-24 15:55 UTC
From: scragz at hotmail dot com Assigned: lsmith
Status: Closed Package: LiveUser
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2004-10-11 02:19 UTC] scragz at hotmail dot com
Description: ------------ The LiveUser::factory (and singleton) method takes $remember as the 5th parameter even though it is not used anywhere in the method. Reproduce code: --------------- - $init = $obj->init($handle, $passwd, $logout); + $init = $obj->init($handle, $passwd, $logout, $remember); That's probably what's supposed to happen. I'm not sure if it works as expected.

Comments

 [2004-10-11 02:37 UTC] scragz at hotmail dot com
Just tested this and it looks like LiveUser::init isn't passing $remember through either. In init: - $lulogin = $this->tryLogin($handle, $passwd); + $lulogin = $this->tryLogin($handle, $passwd, $remember); Then that will be passed to tryLogin() which will finally do something with it.
 [2004-10-11 06:07 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.