Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.7.0

Bug #2367 warning when package has no files in package root dir
Submitted: 2004-09-21 11:11 UTC Modified: 2005-02-20 16:23 UTC
From: smith at backendmedia dot com Assigned: cellog
Status: Closed Package: PEAR_PackageFileManager
PHP Version: 4.3.8 OS: windows xp sp2
Roadmaps: (Not assigned)    
Subscription  


 [2004-09-21 11:11 UTC] smith at backendmedia dot com
Description: ------------ I get the following notice: "Notice: Undefined index: / in c:\php\PEAR\PEAR\PackageFileManager\File.php on line 125" (version 1.2.1) when I run the packagefilemanager on the package.php for either the RDF_N3 or RDF_NTriple package. I assume the problem is that there are no files in the root dir of the package.

Comments

 [2004-09-21 12:30 UTC] cellog
Hi Lukas, I won't have time to properly fix this and do a release for a while, would it be too much trouble to @ line 125 as a stopgap, or does it cause invalid package.xml filelist?
 [2004-09-21 16:43 UTC] smith at backendmedia dot com
no its not really a problem .. just an ugly notice thats all
 [2005-02-08 00:47 UTC] cellog
I forgot to fix this prior to 1.3.0, I'll probably roll 1.3.1 with this fix and anything found in 1.3.0
 [2005-02-20 16:23 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.