Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.10

Bug #2323 destroying container: problem with the back button
Submitted: 2004-09-13 16:26 UTC Modified: 2004-10-01 04:53 UTC
From: ignatius dot reilly at free dot fr Assigned: avb
Status: Closed Package: HTML_QuickForm_Controller
PHP Version: 4.3.8 OS: irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2004-09-13 16:26 UTC] ignatius dot reilly at free dot fr
Description: ------------ For some reason I must clear the QFC container at the end of a successful processing. This causes trouble when the user hits the back button after completing the multipage form (an action that usually has no logic, but which can happen frequently) Reproduce code: --------------- http://auderghem-analytica.com/download/qfc_bug.txt Expected result: ---------------- After the user completes the form and hits the back button, the page called is: http://localhost/wizard.php?_qf_page2_display=true which shows an error message (because the container has been cleared, the variables $GLOBALS['container']['values']['page1']['first_name'], etc. do not exist any more) Actual result: -------------- I would have expected - in the case of a modal form- that such a call be redirected to the page1 display form: http://localhost/wizard.php?_qf_page1_display=true because the container does not contain a ['valid']['page1'] = 1, so it should not show the page 2.

Comments

 [2004-09-15 07:00 UTC] avb
Action_Display does not currently check whether previous pages are valid. Therefore it is possible to access every page of wizard-type form if an URL to it is known without seeing the previous pages. While this does not allow one to submit the invalid wizard, such behaviour is clearly wrong. Will fix ASAP.
 [2004-10-01 04:53 UTC] avb
Fixed in release 1.0.3