Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.11

Bug #21109 IRC bot not working with Slack
Submitted: 2016-09-06 02:06 UTC
From: lock128abc Assigned: garrettw
Status: Closed Package: Net_SmartIRC (version 1.1.9)
PHP Version: 5.6.20 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2016-09-06 02:06 UTC] lock128abc (Johannes Koch)
Description: ------------ I am currently having issues with my IRC bot working with Slack. He is constantely blocking >60% CPU power after the following message in the logfile: Notice: fwrite(): send of 32 bytes failed with errno=32 Broken pipe in /usr/share/php/Net/SmartIRC.php on line 2542 Any ideas? Thanks! Johannes?

Comments

 [2016-09-06 05:38 UTC] lock128abc (Johannes Koch)
From Garret: A "broken pipe" error means that either your bot's connection to Slack was broken, OR (less likely) it could be an issue of character encodings. However, the infinite loop is a bug and I can see what needs to be changed to fix that. Thank you for reporting this.
 [2016-09-14 22:49 UTC] garrettw (Garrett Whitehorn)
-Status: Open +Status: Feedback
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the SVN of the package. Please checking out the SVN repository of this package and upgrade svn checkout svn.php.net/repository/pear/packages/Net_SmartIRC/trunk pear upgrade package2.xml or pear upgrade package.xml If you are able to reproduce the bug with the latest SVN, please change the status back to "Open". Again, thank you for your continued support of PEAR. I just committed some code that should fix your issue. Try that and let me know if it works better for you.
 [2016-09-14 22:50 UTC] garrettw (Garrett Whitehorn)
-Status: Feedback +Status: Open
I just committed some code that should fix your issue. Let me know if that works better.
 [2016-12-13 03:07 UTC] garrettw (Garrett Whitehorn)
-Status: Open +Status: Closed -Assigned To: +Assigned To: garrettw
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. As I never heard anything else from you, I'll assume it's fixed.