Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.1

Bug #21082 Inconsistent licensing
Submitted: 2016-06-16 06:57 UTC
From: legoktm Assigned: ashnazg
Status: Closed Package: Mail (version SVN)
PHP Version: Irrelevant OS: GNU/Linux
Roadmaps: (Not assigned)    
Subscription  


 [2016-06-16 06:57 UTC] legoktm (Kunal Mehta)
Description: ------------ The composer.json file claims the package is BSD-2-clause, however: All files actually have the BSD-3-clause license in their header, except for Mail/sendmail.php which is "version 2.02 of the PHP license". So what exactly is the proper license for this code?

Comments

 [2016-06-17 00:01 UTC] legoktm (Kunal Mehta)
More digging...looks like bug #15620 was never fixed fully?
 [2016-12-28 09:04 UTC] rolek (Roel van Meer)
The license of Mail/sendmail.php prevents this file from being packaged in Debian, due to its strict copyright policy. It would be appreciated if it could be updated to the BSD-3 license, just like the other files. Thanks!
 [2016-12-28 09:27 UTC] alec (Aleksander Machniak)
According to #15620 and https://github.com/pear/Mail/commit/ead639efc855e17508d27f10af05d2dd0aed752a all files should use 2-Clause BSD license. We've had permission from all authors, but the license change was applied only on package.xml file. We have to update the license statement in all files accordingly.
 [2017-02-02 16:08 UTC] rolek (Roel van Meer)
Aleksander, would it help if a patch was provided?
 [2017-02-03 14:40 UTC] jon (Jon Parise)
Yes, let's update Mail/sendmail.php so the license is consistent.
 [2017-02-07 16:03 UTC] rolek (Roel van Meer)
 [2017-03-07 17:59 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Assigned -Assigned To: +Assigned To: chagenbu
chagenbu, can you have a look at the PR?
 [2017-04-06 18:23 UTC] ashnazg (Chuck Burgess)
-Assigned To: chagenbu +Assigned To: ashnazg
 [2017-04-06 18:35 UTC] ashnazg (Chuck Burgess)
Reading through the history on this, I'm not convinced that the originally intended license change was to BSD-2. Since nearly all the files were updated with BSD-3 text, I'm thinking that 2010-02-08 commit by doconner/clockwerx used the wrong URL, along with an ambiguous "BSD Style" name. As such, I'm thinking the proper fix here is: add BSD-3 text to sendmail.php; update license name and link in any files that don't explicitly say "BSD-3" and its opensource.org link. Opinions?
 [2017-04-07 04:53 UTC] rolek (Roel van Meer)
Yes, that seems to be the correct thing to do.
 [2017-04-07 17:08 UTC] ashnazg (Chuck Burgess)
-Status: Assigned +Status: Closed
Fixed in upcoming v1.4.0.