Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.1

Request #2073 PUT and DELETE Support
Submitted: 2004-08-05 23:31 UTC Modified: 2008-10-11 05:04 UTC
From: brandon at osuosl dot org Assigned: avb
Status: Closed Package: HTTP_Client
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2004-08-05 23:31 UTC] brandon at osuosl dot org
Description: ------------ Methods for the HTTP methods PUT and DELTE would be great.

Comments

 [2004-09-15 05:05 UTC] avb
HTTP_Client was designed for simplifying the most common tasks, therefore no PUT and DELETE support. You may consider using HTTP_Request directly, as you can create any kind of request with that.
 [2008-10-10 16:50 UTC] avb (Alexey Borzov)
As this request seems to be quite popular after all, I will implement the delete() and put() methods.
 [2008-10-11 05:04 UTC] avb (Alexey Borzov)
Implemented in CVS