Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.5

Bug #20311 Force push to pear-core ? Normal?
Submitted: 2014-06-24 02:53 UTC
From: fredemmott Assigned: cweiske
Status: Closed Package: PEAR (version SVN)
PHP Version: Irrelevant OS: n/a
Roadmaps: 1.9.5    
Subscription  


 [2014-06-24 02:53 UTC] fredemmott (Fred Emmott)
Description: ------------ https://github.com/pear/pear- core/commit/15dd8a6cceb520226a6546dd09b740cdc3ea4d4c used to be part of master - it's no longer referenced by any branch/tag; if you clone the repository, 'git show 15dd8a6cceb520226a6546dd09b740cdc3ea4d4c' fails to find it. It looks like there was a rebase and force-push - that commit is a merge commit, and https://github.com/pear/pear- core/commit/def22219cfd80fab6f8f8c982fcabbbe9fb41917 appears to be the same change - but it isn't a merge commit, or either of the parents. Was this intentional? Is this something that will be happening again? For context: HHVM tests for regressions against several PHP libraries. We need to pin against specific commits instead of branches, otherwise it would be a poor CI system instead of a regression test. Test script: --------------- git clone https://github.com/pear/pear-core.git git show 15dd8a6cceb520226a6546dd09b740cdc3ea4d4c Expected result: ---------------- This commit: https://github.com/pear/pear- core/commit/15dd8a6cceb520226a6546dd09b740cdc3ea4d4c Actual result: -------------- fatal: bad object 15dd8a6cceb520226a6546dd09b740cdc3ea4d4c

Comments

 [2014-06-27 20:37 UTC] cweiske (Christian Weiske)
-Status: Open +Status: Closed -Assigned To: +Assigned To: cweiske
> Was this intentional? Yes. I re-imported all pear-core commits from SVN because the meta data were wrong. > Is this something that will be happening again? No, the repository is clean now in my eyes.
 [2014-06-27 20:37 UTC] cweiske (Christian Weiske)
-Roadmap Versions: +Roadmap Versions: 1.9.5