Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.3.7

Bug #1976 Missing $this-> with __construct()
Submitted: 2004-07-24 23:58 UTC Modified: 2006-12-26 23:26 UTC
From: rquast at rolandquast dot com Assigned: dufuz
Status: Closed Package: Tree
PHP Version: 5.0.0 OS: Linux 2.4.26-gentoo-r5
Roadmaps: (Not assigned)    
Subscription  


 [2004-07-24 23:58 UTC] rquast at rolandquast dot com
Description: ------------ new __construct constructor in php5 not referencing old constructor correctly.. missing $this-> Reproduce code: --------------- Simple problem I found when installing Tree with php5, the new __construct method cant find the old constructor because its not referencing $this /usr/lib/php/Tree/Dynamic/DBNested.php Line 76: currently... Tree_Dynamic_DBnested( $dsn , $options ); Requires: $this->Tree_Dynamic_DBnested( $dsn , $options );

Comments

 [2004-12-20 15:23 UTC] dufuz
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.