Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.8

Bug #19754 Parse error in mime.php
Submitted: 2012-12-17 08:36 UTC Modified: 2012-12-25 17:23 UTC
From: compman86 Assigned: alec
Status: Closed Package: Mail_Mime (version 1.8.6)
PHP Version: 5.4.2 OS: Unix
Roadmaps: 1.8.7    
Subscription  


 [2012-12-17 08:36 UTC] compman86 (Greg Akselrod)
Description: ------------ The is_error() function had a keyword "private" in front of it, and PHP 4.4.9 choked on it. Since this package claims that it supports PHP 4.3+, please remove the private keyword from the function definition. Since this system wouldn't let me file a bug against 4.*, I had to lie and put PHP version = 5.4.2 instead.

Comments

 [2012-12-25 17:23 UTC] alec (Aleksander Machniak)
-Status: Open +Status: Closed -Assigned To: +Assigned To: alec -Roadmap Versions: +Roadmap Versions: 1.8.7
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.