Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.9

Bug #19473 Compatibility problem PHP 5.4
Submitted: 2012-06-16 18:32 UTC Modified: 2012-07-09 12:17 UTC
From: mjogo Assigned: alec
Status: Closed Package: Mail_Mime (version 1.8.5)
PHP Version: 5.4.3 OS: Suse
Roadmaps: 1.8.6    
Subscription  


 [2012-06-16 18:32 UTC] mjogo (Mar Ppo)
Description: ------------ I got the error message: "Error: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in <my path to pear>/Mail/mime.php on line 1031" It seems that the package is not compatible to PHP 5.4

Comments

 [2012-07-09 12:17 UTC] alec (Aleksander Machniak)
-Status: Open +Status: Closed -Assigned To: +Assigned To: alec
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.