Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.2b2

Bug #19334 "False positive"
Submitted: 2012-03-16 01:27 UTC Modified: 2012-03-16 13:41 UTC
From: ingnu Assigned: am
Status: Closed Package: Net_IPv6 (version 1.2.1)
PHP Version: 5.3.3 OS: Debian GNU/Linux Squeeze
Roadmaps: (Not assigned)    
Subscription  


 [2012-03-16 01:27 UTC] ingnu (Jimmy Rudolf)
Description: ------------ The function checkIPv6 returns true if we add a port number to the address without surrounding the address with square brackets. Test script: --------------- In this example, 48866 is a port number. var_dump(Net_IPv6::checkIPv6("fe80::16da:e9ff:fe0f:6dd4/64:48866")); Expected result: ---------------- bool(false) Actual result: -------------- bool(true)

Comments

 [2012-03-16 12:40 UTC] alexmerz (Alexander Merz)
-Status: Open +Status: Bogus -Assigned To: +Assigned To: am
Thank you for taking the time to write to us, but this is not a bug. The Package checks IPv6 adresses, not IPv6-based URLs. Port numbers are not a part of an adress, so the provided input is not valid for an adress, and is also not valid for an URL according to RFC 2732 requiring you to enclose the adress in square brackets to separate the adress from the port.
 [2012-03-16 12:48 UTC] ingnu (Jimmy Rudolf)
Of course it is not valid, that's exactly why the checkIPv6 function should not return true while testing this example :)
 [2012-03-16 12:51 UTC] alexmerz (Alexander Merz)
-Status: Bogus +Status: Open
Oh sorry, i really missed that point. I reopened the bug.
 [2012-03-16 13:41 UTC] alexmerz (Alexander Merz)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2012-03-16 13:49 UTC] ingnu (Jimmy Rudolf)
Thank you :) BTW, very nice work :)