Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.6

Bug #18892 Parse error in Installer.php
Submitted: 2011-10-06 13:30 UTC
From: jakber Assigned: doconnor
Status: Closed Package: PEAR (version 1.9.4)
PHP Version: 4.4.9 OS: Debian 6
Roadmaps: 1.9.5    
Subscription  


 [2011-10-06 13:30 UTC] jakber (Jakob Berlin)
Description: ------------ After upgrading PEAR to 1.9.4 every install request with pear end up in "Parse error: syntax error, unexpected '(', expecting '}' in /usr/local/lib/php/PEAR/Installer.php on line 811". Test script: --------------- -install Debian 6 -install PHP 4.4.9 from source -upgrade PEAR to 1.9.4 (pear upgrade --force PEAR) -try to install another package Expected result: ---------------- Parse error: syntax error, unexpected '(', expecting '}' in /usr/local/lib/php/PEAR/Installer.php on line 811 Actual result: -------------- Solution: Replce line 811 of Installer.php with this one: "$this->log(3, 'file '.$data[0].' was scheduled for removal from '.$this->pkginfo->getName().' but is owned by '.$new->getChannel().'/'.$new->getName().', removal has been cancelled.');"

Comments

 [2011-10-06 18:22 UTC] doconnor (Daniel O'Connor)
Ouch; I wonder when that got changed between PHP4 and PHP5. http://svn.php.net/viewvc/pear/pear-core/trunk/PEAR/Installer.php? view=markup#l786
 [2011-10-31 17:57 UTC] doconnor (Daniel O'Connor)
-Assigned To: +Assigned To: dufuz
Hey Helgi; are you happy for me to have crack at this if you don't have time?
 [2011-10-31 20:56 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Go for it, attach a patch to this and prod me when it is done.
 [2011-11-16 04:10 UTC] ashnazg (Chuck Burgess)
 [2011-11-16 04:13 UTC] ashnazg (Chuck Burgess)
The attached patch solved the linter/fatal issue for me on PHP 4.4.9.
 [2011-11-16 04:47 UTC] ashnazg (Chuck Burgess)
 [2011-12-10 16:53 UTC] doconnor (Daniel O'Connor)
-Status: Assigned +Status: Closed -Assigned To: dufuz +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2012-06-16 00:24 UTC] doublejosh (Josh Lind)
Just went through "pear upgrade --force Console_Getopt" and "pear upgrade --force pear" and am now stuck with this error. Completely broken and PEAR is now useless to install.
 [2014-05-29 12:28 UTC] cweiske (Christian Weiske)
-Roadmap Versions: +Roadmap Versions: 1.9.5
 [2014-05-31 18:05 UTC] cweiske (Christian Weiske)
Cherry-picked into stable branch for version 1.9.5.