Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.2

Bug #18472 Need to add --non-interactive
Submitted: 2011-04-21 20:20 UTC Modified: 2011-05-10 13:42 UTC
From: mdekrijger Assigned: mrook
Status: Closed Package: VersionControl_SVN (version 0.3.4)
PHP Version: 5.3.5 OS: CentOS
Roadmaps: 0.4.0    
Subscription  


 [2011-04-21 20:20 UTC] mdekrijger (Marco de Krijger)
Description: ------------ Method "prepare" states in the comment " * Prepare the svn subcommand switches. * * Defaults to non-interactive mode, and will auto-set the " But it doesnt, so the $_switches variable needs to be initialized with this --non-interactive option $_switches = '--non-interactive ';

Comments

 [2011-04-22 00:46 UTC] doconnor (Daniel O'Connor)
Any chance of a quick reproducable test case?
 [2011-04-22 08:04 UTC] mrook (Michiel Rook)
-Roadmap Versions: +Roadmap Versions: 0.4.0
 [2011-05-10 08:33 UTC] mdekrijger (Marco de Krijger)
 [2011-05-10 08:39 UTC] mdekrijger (Marco de Krijger)
I just added a patch which would resolve the problem. I can't give full reproduction code. But I can try to describe the problem when it occurs; I use Phing to deploy PHP code to live environments. When doing so I check the workingcopy version against the repository revision, if it doesn't match then it will fail the publication. For this purpose I use the phing SvnLastRevisionTask http://www.phing.info/docs/guide/stable/chapters/appendixes/AppendixC-OptionalTasks.html#SvnLastRevisionTask The code behind this task uses the PEAR SVN package, and as expected the Info.php file. When using this phing task, it will fail because it expects a SVN username and password at prompt, which can't be done because Phing is already executing its code. So that's why this --non-interactive mode should be added to the switches. Or at least as an extra option (a setter method) that can be configured from Phing, so they can add it to their task.
 [2011-05-10 13:42 UTC] mrook (Michiel Rook)
-Status: Open +Status: Closed -Assigned To: +Assigned To: mrook
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.