Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.3

Bug #18376 EAN13 code does not correctly calculate image width
Submitted: 2011-03-19 01:34 UTC
From: coldtobi Assigned: doconnor
Status: Closed Package: Image_Barcode (version 1.1.1)
PHP Version: 5.3.1 OS:
Roadmaps: (Not assigned)    

 [2011-03-19 01:34 UTC] coldtobi (Tobias Frost)
Description: ------------ ... when using the feature to change the barcode image size, this bugs triggers. (see feature request The problem is that the EAN13 code does not use barwidth for the left-bars, center bars and right bars. So when increasing barwidth, the image "gets cut off". The attached patch fixes this.


 [2011-03-19 01:35 UTC] coldtobi (Tobias Frost)
 [2011-12-10 17:46 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on by the end of next Sunday (CET). If this was a problem with the website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.