Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.0

Bug #18189 Patch:many undefined indexes, like TEL in File_IMC_Build_Vcard->addTelephone()
Submitted: 2011-01-12 23:10 UTC Modified: 2011-01-13 13:24 UTC
From: radoeka Assigned:
Status: Duplicate Package: File_IMC (version 0.4.1)
PHP Version: 5.3.1 OS: linux
Roadmaps: 0.4.2    
Subscription  


 [2011-01-12 23:10 UTC] radoeka (Richard Bos)
Description: ------------ Patch:many undefined indexes, like this: TEL in File_IMC_Build_Vcard->addTelephone() (regel 1109 van /usr/share/php5/PEAR/File/IMC/Build/Vcard.php) For details see: http://drupal.org/node/1021962 I've a patch attached. Hopefully, you can commit it right away, that would be nice. Test script: --------------- I use drupal, that creates a vcard for me. The undefined notices are shown after the creation of the vcard on the webinterface. It makes Drupal looking quite bad :( Expected result: ---------------- No notices on the webinterface. Actual result: -------------- Many of those lines: * Notice: Undefined index: TEL in File_IMC_Build_Vcard- /usr/share/php5/PEAR/File/IMC/Build/Vcard.php). * Notice: Undefined index: ADR in File_IMC_Build_Vcard- /usr/share/php5/PEAR/File/IMC/Build/Vcard.php). * Notice: Undefined index: NAME in File_IMC_Build_Vcard- /usr/share/php5/PEAR/File/IMC/Build/Vcard.php). * Notice: Undefined index: SOURCE in File_IMC_Build_Vcard- /usr/share/php5/PEAR/File/IMC/Build/Vcard.php). * Notice: Undefined index: PHOTO in File_IMC_Build_Vcard- /usr/share/php5/PEAR/File/IMC/Build/Vcard.php).

Comments

 [2011-01-12 23:10 UTC] radoeka (Richard Bos)
 [2011-01-13 13:24 UTC] radoeka (Richard Bos)
-Status: Open +Status: Duplicate
Duplicate of Bug #18188