Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.7

Bug #17995 error after upgrade to 1.0.6
Submitted: 2010-10-25 17:51 UTC Modified: 2011-01-03 12:07 UTC
From: bigmichi1 Assigned: bate
Status: Closed Package: Net_DNS (version 1.0.6)
PHP Version: 5.3.3 OS: Ubuntu 10.10
Roadmaps: (Not assigned)    
Subscription  


 [2010-10-25 17:51 UTC] bigmichi1 (Michael Cramer)
Description: ------------ 2010-10-25 19:41:46: (mod_fastcgi.c.2711) FastCGI-stderr: PHP Fatal error: Call to undefined method Net_DNS_RR_NS::dn_expand() in /home/apache/horde-webmail- 1.2.7/pear/php/Net/DNS/Packet.php on line 427 i think this fix is wrong, now Net_DNS breaks entirely instead of throwing only a warning http://pear.php.net/bugs/bug.php?id=17743

Comments

 [2010-10-25 20:14 UTC] yunosh (Jan Schneider)
There's also a notice, and here are the full backtraces: ( ! ) Notice: Undefined property: Net_DNS_RR_SOA::$INT16SZ in /usr/share/php/Net/DNS/Packet.php on line 421 Call Stack # Time Memory Function Location 1 0,0060 1219136 {main}( ) ../message.php:0 2 0,4993 23748152 NLS::generateFlagImageByHost( ) ../message.php:404 3 0,4993 23748152 NLS::getCountryByHost( ) ../NLS.php:573 4 0,5216 25369504 Net_DNS_Resolver->query( ) ../NLS.php:528 5 0,5216 25369640 Net_DNS_Resolver->rawQuery( ) ../Resolver.php:672 6 0,5228 25378536 Net_DNS_Resolver->send( ) ../Resolver.php:650 7 0,5238 25380296 Net_DNS_Resolver->send_udp( ) ../Resolver.php:704 8 0,5238 25380296 Net_DNS_Resolver->send_udp_with_sock_lib( ) ../Resolver.php:1118 9 0,7004 25385152 Net_DNS_Packet->parse( ) ../Resolver.php:1070 10 0,7018 25390656 Net_DNS_Packet->parse_rr( ) ../Packet.php:269 11 0,7022 25393480 Net_DNS_RR->factory( ) ../Packet.php:577 12 0,7022 25393616 Net_DNS_RR->new_from_data( ) ../RR.php:83 13 0,7023 25397216 Net_DNS_RR_SOA->Net_DNS_RR_SOA( ) ../RR.php:103 14 0,7024 25397480 Net_DNS_Packet->dn_expand( ) ../SOA.php:57 ( ! ) Fatal error: Call to undefined method Net_DNS_RR_SOA::dn_expand() in /usr/share/php/Net/DNS/Packet.php on line 427 Call Stack # Time Memory Function Location 1 0,0060 1219136 {main}( ) ../message.php:0 2 0,4993 23748152 NLS::generateFlagImageByHost( ) ../message.php:404 3 0,4993 23748152 NLS::getCountryByHost( ) ../NLS.php:573 4 0,5216 25369504 Net_DNS_Resolver->query( ) ../NLS.php:528 5 0,5216 25369640 Net_DNS_Resolver->rawQuery( ) ../Resolver.php:672 6 0,5228 25378536 Net_DNS_Resolver->send( ) ../Resolver.php:650 7 0,5238 25380296 Net_DNS_Resolver->send_udp( ) ../Resolver.php:704 8 0,5238 25380296 Net_DNS_Resolver->send_udp_with_sock_lib( ) ../Resolver.php:1118 9 0,7004 25385152 Net_DNS_Packet->parse( ) ../Resolver.php:1070 10 0,7018 25390656 Net_DNS_Packet->parse_rr( ) ../Packet.php:269 11 0,7022 25393480 Net_DNS_RR->factory( ) ../Packet.php:577 12 0,7022 25393616 Net_DNS_RR->new_from_data( ) ../RR.php:83 13 0,7023 25397216 Net_DNS_RR_SOA->Net_DNS_RR_SOA( ) ../RR.php:103 14 0,7024 25397480 Net_DNS_Packet->dn_expand( ) ../SOA.php:57
 [2010-10-25 21:57 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Feedback
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the SVN of the package. Please checking out the SVN repository of this package and upgrade svn checkout svn.php.net/repository/pear/packages/Net_DNS/trunk pear upgrade package2.xml or pear upgrade package.xml If you are able to reproduce the bug with the latest SVN, please change the status back to "Open". Again, thank you for your continued support of PEAR. Hi guys, Try the changes in r304897
 [2010-10-26 07:35 UTC] yunosh (Jan Schneider)
Unfortunately this code path is only followed on error conditions that happens like 1 or 2 times a month for me. So it's almost impossible to say if this is gone, unless you want to wait a month for the next release.
 [2010-11-03 10:22 UTC] bate (Marco Kaiser)
i added some changes in svn
 [2011-01-03 12:05 UTC] yunosh (Jan Schneider)
FWIW, I haven't seen this error since then.
 [2011-01-03 12:07 UTC] bate (Marco Kaiser)
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: bate
seems to be fixed