Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.7

Bug #17988 Parse error: syntax error, unexpected T_STATIC
Submitted: 2010-10-24 15:53 UTC Modified: 2010-10-25 00:24 UTC
From: ronnyadsetts Assigned: doconnor
Status: Closed Package: Net_DNS (version 1.0.5)
PHP Version: 4.4.4 OS: Debian Linux
Roadmaps: (Not assigned)    
Subscription  


 [2010-10-24 15:53 UTC] ronnyadsetts (Ronny Adsetts)
Description: ------------ With PHP4, Net/DNS/Resolver.php fails to lint with a parse error. The error is NOT there in Net_DNS 1.0.3. $ php -l Net/DNS/Resolver.php Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in Net/DNS/Resolver.php on line 241 Errors parsing Net/DNS/Resolver.php Yell if you need more information. NB. Yes, I know I should upgrade to a newer version of PHP. Not an immediate option though unfortunately.

Comments

 [2010-10-24 15:56 UTC] ronnyadsetts (Ronny Adsetts)
Correction to last, the problem is NOT there in v1.0.1. Bit of a brain fart previously.
 [2010-10-25 00:22 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Verified
static $parsedfiles = array(); Introduced in r302038 / Bug #17678
 [2010-10-25 00:24 UTC] doconnor (Daniel O'Connor)
-Status: Verified +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Completed: At revision: 304719