Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.5.0b5

Bug #17909 Undefined index: _MDB2_dsninfo_default
Submitted: 2010-09-29 14:23 UTC Modified: 2011-03-11 18:50 UTC
From: till Assigned: quipo
Status: Bogus Package: MDB2 (version 2.5.0b3)
PHP Version: 5.3.2 OS: ubuntu
Roadmaps: 2.5.0b4    
Subscription  


 [2010-09-29 14:23 UTC] till (Till Klampaeckel)
Description: ------------ 3) Mail_Queue_ContainerTest::testSendMailByIdWithInvalidId Undefined index: _MDB2_dsninfo_default /usr/share/php/MDB2.php:796 /usr/share/php/MDB2.php:371 /usr/share/php/MDB2.php:417 /home/till/Mail_Queue/trunk/tests/Mail/QueueAbstract.php:89 /home/till/Mail_Queue/trunk/tests/Mail/QueueAbstract.php:45 Test script: --------------- svn co http://svn.php.net/repository/pear/packages/Mail_Queue/trunk/ ./Mail_Queue cd Mail_Queue/tests phpunit Expected result: ---------------- No undefined index error. Actual result: -------------- Undefined index error.

Comments

 [2010-09-29 14:44 UTC] till (Till Klampaeckel)
I had this code in my setup: include_once "MDB2.php"; include_once "MDB2/Driver/sqlite.php"; if (!class_exists('MDB2')) { $this->skip("MDB2 is necessary to run these tests: pear install MDB2"); } if (!class_exists('MDB2_Driver_sqlite')) { $this->skip("MDB2's sqlite driver is necessary to run these tests: pear install MDB2#sqlite"); } To gracefully skip when it's not installed. When I comment it out, the undefined index is not triggered. Any idea why?
 [2010-09-29 14:45 UTC] till (Till Klampaeckel)
When I say "setup", I mean: "setUp()" method.
 [2011-03-06 13:55 UTC] quipo (Lorenzo Alberton)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: quipo
I can't reproduce, sorry. Can you try with the SVN version of MDB2, please?
 [2011-03-11 18:50 UTC] till (Till Klampaeckel)
-Status: Feedback +Status: Bogus
Sorry, but your problem does not imply a bug in PEAR itself. For a list of more appropriate places to ask for help using PEAR, please visit http://pear.php.net/support/ as this bug system is not the appropriate forum for asking support questions. Thank you for your interest in PEAR. Me neither. ;-)