Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.7

Bug #17893 Different values in SOA records
Submitted: 2010-09-24 13:04 UTC Modified: 2010-11-03 10:28 UTC
From: scott Assigned: bate
Status: Closed Package: Net_DNS (version 1.0.5)
PHP Version: 5.2.12 OS: FreeBSD 8.1 amd64
Roadmaps: (Not assigned)    
Subscription  


 [2010-09-24 13:04 UTC] scott (Scott Langley)
Description: ------------ When I query the auth nameserver for a SOA record of a domain the Net_DNS package reports different values for the serial, refresh, retry and expire records. I did find this other bug report with id 10805 which seems related but was reported to be fixed with a newer snapshot of version 5.2 back in 2007. We run the most recent version: # php -v PHP 5.2.14 with Suhosin-Patch 0.9.7 (cli) (built: Sep 7 2010 12:23:31) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies # Test script: --------------- <?php require_once 'Net/DNS.php'; $resolver = new Net_DNS_Resolver(); $resolver->debug = 1; $resolver->nameservers = array('109.72.172.22'); $response = $resolver->rawQuery('dedicatedxl.com', 'SOA', 'IN'); echo "\n\nDIG OUTPUT\n\n"; echo passthru("/usr/bin/dig @109.72.172.22 dedicatedxl.com IN SOA"); ?> You can see it in action here: http://www.serveradmintoolbox.com/test.php Expected result: ---------------- You will see that the Net DNS pear package reports this SOA record: dedicatedxl.com. 86400 IN SOA ns1.servers.dedicatedxl.net. hostmaster.dedicatedxl.net. 3224991695 2460483584 707788800 235929609 981467136 while you will see this result (with the valid serial number and expire/ttl values) with the dig command: dedicatedxl.com. 86400 IN SOA ns1.servers.dedicatedxl.net. hostmaster.dedicatedxl.net. 2010092200 10800 3600 604800 3600 You will see that the serial, refresh, retry and expire values are different.

Comments

 [2010-09-24 13:20 UTC] skion (Pieter Ennes)
I can confirm, and see negative values for serial, retry and refresh even. <? require 'Net/DNS.php'; $pear = new Net_DNS_Resolver(); $pear->nameservers = array('ns-1.sourceforge.com.'); print_r($pear->query('slashdot.org', 'SOA')); ?> [answer] => Array ( [0] => Net_DNS_RR_SOA Object ( [name] => slashdot.org [type] => SOA [class] => IN [ttl] => 3600 [rdlength] => 64 [rdata] => ns-1ch3 sourceforgecom hostmastercorp?3w??`8@ :? [mname] => ns-1.ch3.sourceforge.com [rname] => hostmaster.corp.sourceforge.com [serial] => -1070368818 [refresh] => -278921216 [retry] => 943718400 [expire] => 117964809 [minimum] => 981467136 ) ) This happens on 1.0.5, but 1.0.0 and 1.0.1 seem to work correctly.
 [2010-09-27 06:30 UTC] bate (Marco Kaiser)
-Assigned To: +Assigned To: bate
Are you sure? the difference between 1.0 and 1.0.5 are not related to this issue type or queries ... i try to investigate some time into this issue ...
 [2010-09-27 14:43 UTC] scott (Scott Langley)
I have tried it with the 1.0 package of Net_DNS but I get the same incorrect results.
 [2010-09-27 16:32 UTC] scott (Scott Langley)
I have also run the script of Pieter, this my output: [answer] => Array ( [0] => Net_DNS_RR_SOA Object ( [name] => slashdot.org [type] => SOA [class] => IN [ttl] => 3600 [rdlength] => 64 [rdata] => ns-1ch3 sourceforgecom? hostmastercorpÀ3wÎï`??8@??? :€?? [mname] => ns-1.ch3.sourceforge.com [rname] => hostmaster.corp.sourceforge.com [serial] => 3224598478 [refresh] => 4016046080 [retry] => 943718400 [expire] => 117964809 [minimum] => 981467136 ) )
 [2010-10-26 16:55 UTC] jerrywilborn (Jerry Wilborn)
I believe this was caused by http://pear.php.net/bugs/bug.php?id=17743 (Which is fixed in 1.0.6)
 [2010-11-03 10:28 UTC] bate (Marco Kaiser)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.