Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.2.1

Request #17506 Add more exception classes
Submitted: 2010-06-21 11:22 UTC Modified: 2010-06-23 10:32 UTC
From: till Assigned:
Status: Duplicate Package: HTTP_Request2 (version 0.5.2)
PHP Version: 5.3.2 OS: Ubuntu
Roadmaps: (Not assigned)    
Subscription  


 [2010-06-21 11:22 UTC] till (Till Klampaeckel)
Description: ------------ So this is also re #16762. I get an exception which says: "Malformed request:" and I have to start grepping through the code base to figure out where it's from. I'd propose the following: HTTP_Request2_AdapterException HTTP_Request2_ResponseException ... the first for all exceptions that come from the adapter underneath, and the second for when the response handling didn't work. Thoughts?

Comments

 [2010-06-23 09:47 UTC] avb (Alexey Borzov)
-Status: Open +Status: Duplicate
Duplicate of request #16762 Let's keep Exception-related discussion there.
 [2010-06-23 10:07 UTC] till (Till Klampaeckel)
-Status: Duplicate +Status: Feedback
It's a different feature request though. One is for meaningful error codes, the other is more exception classes.
 [2010-06-23 10:32 UTC] avb (Alexey Borzov)
-Status: Feedback +Status: Duplicate
The discussion there deals with both.