Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.7.3

Bug #17183 MDB2 container doesn't work with APC
Submitted: 2010-03-02 12:53 UTC Modified: 2010-03-02 14:22 UTC
From: pgarcia Assigned: till
Status: Closed Package: HTTP_Session2 (version 0.7.2)
PHP Version: 5.2.12 OS: CentOs 5.4
Roadmaps: 0.7.3, 0.8.0    
Subscription  


 [2010-03-02 12:53 UTC] pgarcia (Prudencio Garcia)
Description: ------------ HTTP_Sessions2 doesn't work with APC and PHP > 5.2.9 if you use MDB2 container. Detailed information about this issue can be found in http://pecl.php.net/bugs/bug.php?id=16745 The problem is fixed with the following patch: --- HTTP/Session2/Container.php 2009-11-13 16:18:45.000000000 +0000 +++ HTTP.new/Session2/Container.php 2010-02-26 09:14:11.000000000 +0000 @@ -125,4 +125,14 @@ array($this, 'destroy'), array($this, 'gc')); } -} \ No newline at end of file + + /** + * Call session_write_close() in destructor for compatibility with PHP >= 5.0.5 + * + * @return void + */ + public function __destruct() + { + session_write_close(); + } +}

Comments

 [2010-03-02 14:17 UTC] till (Till Klampaeckel)
-Assigned To: +Assigned To: till
 [2010-03-02 14:22 UTC] till (Till Klampaeckel)
-Status: Assigned +Status: Closed -Roadmap Versions: +Roadmap Versions: 0.8.0
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.