Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.11.5

Bug #1697 createTables.php removes a line when updating a table file
Submitted: 2004-06-22 00:19 UTC
From: justinpatrin Assigned: alan_k
Status: Closed Package: DB_DataObject
PHP Version: 4.3.6 OS: Linux
Roadmaps: (Not assigned)    

 [2004-06-22 00:19 UTC] justinpatrin
Description: ------------ When createTables.php updates a previously created PHP file for a table, this line disappears: class DataObject_PoTrackingOrder extends DB_DataObject { - ###START_AUTOCODE /* the code below is auto generated do not remove the above tag */ Reproduce code: --------------- Run createTables.php for the first time, check for the line, then run it again. Changing this line: $body = "\n ###START_AUTOCODE\n"; to this: $body = " ###START_AUTOCODE\n"; should fix the problem. Expected result: ---------------- The line stays or is not entered at all. Actual result: -------------- The line is entered, then disappears.


 [2004-06-29 09:52 UTC] alan_k
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on In case this was a website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Hopefully the fix in CVS should fix that.. - I removed the extra line from the inital generation.. - as It looks likely to be a less dangerous fix..