Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.3

Bug #16936 ini_get(open_basedir) falseproblem
Submitted: 2009-12-21 12:10 UTC Modified: 2009-12-22 02:52 UTC
From: stappel Assigned:
Status: Duplicate Package: Spreadsheet_Excel_Writer (version 0.9.2)
PHP Version: 5.2.5 OS: Fedora Linux 11
Roadmaps: (Not assigned)    
Subscription  


 [2009-12-21 12:10 UTC] stappel (Stanley Appel)
Description: ------------ After upgrading from v0.9.1 to v0.9.2 my scripts took 10 times as long to excute. I tracked it down to a problem with the ini_get() which was added to v0.9.2. Now it always failes to open a tmp file and that is why it takes so long. If open_basedir is enabled ini_get('open_basedir') will return true, not false. To fix in worksheet.php: - if ($this->_tmp_dir === '' && ini_get('open_basedir') === false) { + if ($this->_tmp_dir === '' && ini_get('open_basedir') === true) { Test script: --------------- . Expected result: ---------------- Speedy response.

Comments

 [2009-12-22 02:52 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Duplicate
Dupe of #16938 (it's got a patch)