Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.2

Bug #16892 SVN.run() on windows doesn't execute properly
Submitted: 2009-12-08 19:23 UTC Modified: 2009-12-30 23:41 UTC
From: shaneneuerburg Assigned: mrook
Status: Closed Package: VersionControl_SVN (version 0.3.3)
PHP Version: 5.3.1 OS: Windows Vista Business
Roadmaps: 0.3.4    
Subscription  


 [2009-12-08 19:23 UTC] shaneneuerburg (Shane Neuerburg)
Description: ------------ When doing an SVN checkout on a Windows machine ("Uniform Server" as server platform, so a WAMP setup), I receive the following error: "Failed to run the 'svn checkout' command: The filename, directory name, or volume label syntax is incorrect." The SVN executable was set to "svn" is set in the PATH environment variable. The command it executed was (including double quotes): ""svn" checkout --username [omitted] --password [omitted] --no-auth-cache -r HEAD --non-interactive svn://10.42.10.66/test/trunk G:\Web\deployment" In order to fix the issue, I had to change the code to the following (note the added "cmd /C" prefix): if (!$this->passthru) { exec("cmd /C $cmd 2>&1", $out, $ret_var); } else { passthru("cmd /C $cmd 2>&1", $ret_var); }

Comments

 [2009-12-30 23:41 UTC] mrook (Michiel Rook)
-Status: Open +Status: Closed -Assigned To: +Assigned To: mrook -Roadmap Versions: +Roadmap Versions: 0.3.4
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2010-01-13 02:49 UTC] marknettle (Mark Nettle)
I'm encountering a similar problem. I'm using svnmanager (which uses VersionControl_SVN) on a windows 2003 server box. The fix given here (and in 0.3.4) doesn't solve this problem for me, I get: 'cmd' is not recognized as an internal or external command Command used: "C:\WINDOWS\system32\cmd.exe /C c:\PROGRA~1\Collab~1\Subver~1\svn list --config-dir e:\svnconfig --non-interactive file:///e:/svn/test" Note: the double quotes are actually in the command. That's what causes the "filename, directory name, of volume label syntax is incorrect" error. As it's already using "cmd.exe /C" (is that coming from VersionControl_SVN or svnmanager??), I removed the double quotes by commenting out line 654 of SVN.php, and it runs fine for me.