Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #16644 pear.bat returns syntax error when parenthesis are in install path.
Submitted: 2009-09-25 16:04 UTC Modified: 2010-03-29 00:42 UTC
From: bwaters Assigned: dufuz
Status: Closed Package: PEAR (version 1.9.0)
PHP Version: 5.3.0 OS: Vista-64bit
Roadmaps: (Not assigned)    
Subscription  


 [2009-09-25 16:04 UTC] bwaters (Bryan Waters)
Description: ------------ When installed under C:\Program Files (x86)\ pear returns syntax error because the include_path directive is not properly quoted Test script: --------------- C:\Program Files(x86)\Zend\ZendServer\bin>pear Expected result: ---------------- list of commands.... Actual result: -------------- Alert box form php thrown - Syntax Error, unexpected '(' in Unknown on Line 14

Comments

 [2009-09-25 16:13 UTC] bwaters (Bryan Waters)
Fixed in pear.bat changed quoting of include_path directive at the end of the file to "include_path='%VARIABLE%'" The double quotes get it through the windows shell and the single quotes are used by php. The actual line now reads. "%PHP_PEAR_PHP_BIN%" -C -d output_buffering=1 -d safe_mode=0 -d open_basedir="" -d auto_prepend_file="" -d auto_append_file="" -d variables_order=EGPCS -d register_argc_argv="On" -d "include_path='%PHP_PEAR_INSTALL_DIR%'" -f "%PHP_PEAR_INSTALL_DIR%\pearcmd.php" -- %1 %2 %3 %4 %5 %6 %7 %8 %9
 [2010-03-28 23:33 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Summary: pear returns syntax error when parenthesis are in install path. +Summary: pear.bat returns syntax error when parenthesis are in install path.
 [2010-03-28 23:35 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Open +Status: Closed -Assigned To: +Assigned To: dufuz
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Thanks a lot for the patch! Confirmed that fixed it on XP and the fix will be included in PEAR 1.9.1
 [2010-03-29 00:42 UTC] danielc (Daniel Convissor)
Bug 16596 marked duplicate of this.
 [2012-05-12 21:30 UTC] tkli (Tom Klingenberg)
 [2013-05-27 11:53 UTC] sascham78 (Sascha Meyer)
Bug still exists in latest PHP 5.3 Windows version: VC9 x86 Non Thread Safe (2013-May-08 19:29:07) Configuration entry has not been fixed in go-pear.phar in line 31780, still creates same error when installing on Windows system.
 [2013-05-27 11:57 UTC] sascham78 (Sascha Meyer)
Wrong line number given, correct line would be 66834.
 [2013-12-18 00:27 UTC] juliandunn (Julian Dunn)
Seeing this as well. How do we reopen a bug that's been closed already?