Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.16.14

Bug #1654 error in perm init
Submitted: 2004-06-16 07:05 UTC Modified: 2006-12-24 15:41 UTC
From: xav at spotk dot net Assigned: lsmith
Status: Closed Package: LiveUser
PHP Version: 4.3.7 OS: linux debian sarge
Roadmaps: (Not assigned)    
Subscription  


 [2004-06-16 07:05 UTC] xav at spotk dot net
Description: ------------ on LiveUser init, if the user has not been created in the Perm container, the sequence: LiveUser_Perm_Container_DB_Medium:: init() >> readRights() >> readGroups() generate an SQL error. the problem is located in Perm/Container /DB_Medium.php in init() presence of a not null record should be checked and null value must not be assigned to permUserId property. Reproduce code: --------------- $e = $usr->init(); only if the authenticated user is not present in the perm container. Expected result: ---------------- LiveUser init complete smoothly Actual result: -------------- SELECT GU.group_id FROM liveuser_groupusers GU INNER JOIN liveuser_groups G ON GU.group_id=G.group_id WHERE G.is_active='Y' AND perm_user_id= [nativecode=ERROR: syntax error at end of input at character 311]

Comments

 [2004-06-16 14:26 UTC] arnaud
While the current situation is not ideal the implementation of ErrorStack should solve that. Please wait until release 0.13.
 [2004-06-17 09:36 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.