Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Request #1649 It would be nice to be able to attach a file to a bug report
Submitted: 2004-06-15 11:37 UTC Modified: 2007-03-06 18:23 UTC
From: justinpatrin Assigned: cellog
Status: Closed Package: pearweb
PHP Version: Irrelevant OS: N/A
Roadmaps: 1.9.0    
Subscription  


 [2004-06-15 11:37 UTC] justinpatrin
Description: ------------ Allow users to attach a file to a bug report would be a huge help as not all users have a webserver to easily post a patch to. In addition, this would keep patches in one place rather than have them floating around on various servers.

Comments

 [2005-02-07 14:29 UTC] dufuz
I'll tackle this when I've time and have finished adding somet other more useful features. The idea would be to limit each patch to 20kb or something long that lines, and only allow it to be .diff and things like that, try to keep things a little strict :) I've not decided upon if I want to allow multiple patches per bug report (which in turns would mean more hard disk space usage, which might not be ideal) This is a issue I and the webmaster team have to discuss, as well as the system administrators.
 [2006-02-18 06:45 UTC] techtonik
1 year time out. =/ Anybody to make a short report/overview on the problem with possible solutions?
 [2006-02-19 21:30 UTC] pajoye
will be commited this week
 [2006-06-09 17:17 UTC] olivierg at php dot net (Olivier Guilyardi)
I do need this feature. What's up ?
 [2006-06-09 17:55 UTC] pajoye (Pierre-Alain Joye)
A lot of people needs it. It is coming. There is other issues to fix before adding this feature.
 [2006-12-06 02:20 UTC] bablu2anil at rediffmail dot com
asadsdsadas
 [2007-03-06 18:08 UTC] wiesemann (Mark Wiesemann)
This was (almost) fixed by Greg.
 [2007-03-06 18:10 UTC] cellog (Greg Beaver)
what do you mean almost? it works, with the exception of that weird warning, which I can't reproduce locally, of course :)
 [2007-03-06 18:23 UTC] cellog (Greg Beaver)
everything is peachy, closing