Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #16366 compiling 5.2.10 leads to non-functioning pear
Submitted: 2009-06-22 19:04 UTC Modified: 2009-08-28 09:00 UTC
From: adam_a Assigned: dufuz
Status: Closed Package: PEAR
PHP Version: 5.2.10 OS: Solaris 9
Roadmaps: 1.9.0    
Subscription  


 [2009-06-22 19:04 UTC] adam_a (Adam Arrowood)
Description: ------------ compiling php 5.2.10 with pear support leads to warnings on install and non-functional pear. Compilation of php 5.2.9 on same box with same config options gives working pear. Test script: --------------- make install in source directory produces errors like: Warning: Cannot use a scalar value as an array in phar://install-pear-nozlib.phar/PEAR/ChannelFile.php on line 1391 running "pear install DB" produces the error: pear.php.net is using a unsupported protocal - This should never happen.

Comments

 [2009-06-22 19:07 UTC] adam_a (Adam Arrowood)
Compile options (with gcc 3.4.6): CC=gcc \ export LD_LIBRARY_PATH=/usr/local/ssl/lib:/opt/services/amp/lib:/usr/local/lib export PATH=/opt/SUNWspro/bin:/usr/ccs/bin:/usr/sbin:/usr/bin:/local/ssl/bin:/usr/xpg4/bin/:/services/mysql/bin:/opt/services/amp/bin:/usr/local/bin export LDFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib" export CFLAGS="-R/opt/services/amp/lib -L/opt/services/amp/lib -R/usr/local/ssl/lib -L/usr/local/ssl/lib -R/usr/local/lib -L/usr/local/lib" SSL_BASE=/opt/local/ssl \ ./configure \ --with-apxs2=/opt/services/amp/apache2/bin/apxs \ --prefix=/opt/services/amp/apache2/php \ --with-config-file-path=/opt/services/amp/apache2/php/lib \ --with-mysql=/services/mysql \ --with-mysqli=/services/mysql/bin/mysql_config \ --with-ldap=/usr/local/ldap \ --with-mcrypt \ --with-curl=/opt/services/amp \ --with-openssl \ --with-gd \ --with-zlib=/usr/local \ --enable-mbstring \ --with-xsl=/opt/services/amp \ --with-libxml-dir=/opt/services/amp \ --with-jpeg-dir=/usr/local \ --with-png-dir=/usr/local \ --with-freetype-dir=/usr/local \ --enable-libgcc
 [2009-06-22 19:45 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Package: pearweb +Package: PEAR
 [2009-06-23 15:12 UTC] cweiske (Christian Weiske)
User "phiber_" experienced this on 5.2.10 and 5.2.9 on centos. adam_a only on 5.2.10, not on 5.2.9, and all this on solaris. Brett Bieber and Bjori could not reproduce it at all.
 [2009-06-28 22:57 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Which libxml2 do the users that have issues?
 [2009-08-11 21:03 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Open +Status: Closed -Assigned To: +Assigned To: dufuz -Roadmap Versions: +Roadmap Versions: 1.9.0
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2009-08-12 08:58 UTC] jani (Jani Taskinen)
-Status: Closed +Status: Assigned
What does "it's fixed" mean? Is is fixed so that if I now do 'make install-pear' and it grabs the phar thing from net it will work? (hint: I tried it, it still fails the same way)
 [2009-08-19 15:10 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Assigned +Status: Closed
As the status message said, it's fixed in CVS / SVN and is pending a release. If you read the message it does not say "fixed in release", phars are only ever updated on stable releases.
 [2009-08-28 09:00 UTC] cweiske (Christian Weiske)
You can fix the protocol error on an existing installation: http://blog.pear.php.net/2009/08/28/fixing-unsupported-protocol/