Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.4.3

Bug #1620 doesn't work with XML_Parser > 1.0.1 (even latest stable)
Submitted: 2004-06-12 07:35 UTC
From: neufeind Assigned: mike
Status: Closed Package: System_ProcWatch
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 30 = ?

 
 [2004-06-12 07:35 UTC] neufeind
Description: ------------ The procwatch-scripts don't work if you have installed XML_Parser > 1.0.1 (e.g. the latest stable). Reproduce code: --------------- system-procwatch.php that ships with the package under /scripts Expected result: ---------------- work :-) Actual result: -------------- $this->parser is not set. This is due to a change in XML_Parser. Since 1.1.0beta1 XML_Parser now has a public function "reset()" that is also used internally during object-creation. However, ProcWatch defines reset() itself in the derived class. Solution: Remove reset() from class System_ProcWatch_Config_Parser, since it's already defined (and works well) in XML_Parser itself from which this class extends.

Comments

 [2004-06-12 13:20 UTC] mike
I'm on it :)
 [2004-06-12 13:37 UTC] mike
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/System_ProcWatch Thanks a lot, Stefan. I should visit /var/log/php more often...