Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.5

Request #16070 Select Imagick2 but id dosen't work on PHP5
Submitted: 2009-04-04 20:01 UTC Modified: 2011-03-17 10:46 UTC
From: fkrauthan Assigned: cweiske
Status: Closed Package: Image_Transform (version CVS)
PHP Version: 5.2.9 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2009-04-04 20:01 UTC] fkrauthan (Florian Krauthan)
Description: ------------ If you use PHP5 an you would select the Imagick Driver Image_Transform use imagick2 automaticly. But on PHP5 it dosen't work so you must use Imagick3 on PHP 5

Comments

 [2009-04-04 20:02 UTC] fkrauthan (Florian Krauthan)
The following patch has been added/updated: Patch Name: imagick_version-diffrent-php-versions Revision: 1238875331 URL: http://pear.php.net/bugs/patch-display.php?bug=$bug&patch=$patch_name&revision=$e&display=1
 [2009-04-11 19:38 UTC] doconnor (Daniel O'Connor)
Thanks for the patch! It could do with a bit of cleanup to better conform to the pear coding standards; but it gives the maintainer enough to go on.
 [2010-08-10 09:25 UTC] pvoss (Paul Voss)
The patch by Florian Krauthan works perfect. Thanks! I wonder why it hasn't been incorporated into a new Image_Transform version yet.
 [2011-03-17 09:48 UTC] cweiske (Christian Weiske)
I can confirm this bug, and it basically makes Image_Transform unusable on systems with PHP5 and imagick installed.
 [2011-03-17 10:46 UTC] cweiske (Christian Weiske)
-Status: Open +Status: Closed -Assigned To: +Assigned To: cweiske
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/ Fixed in release 0.9.4. I modified your patch a bit.