Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.5

Bug #16046 upgrading phpunit/phpunit-beta fails, -version works
Submitted: 2009-03-19 12:04 UTC Modified: 2009-03-27 06:40 UTC
From: cweiske Assigned: dufuz
Status: Bogus Package: PEAR (version CVS)
PHP Version: 5.2.9 OS:
Roadmaps: 1.8.0    
Subscription  


 [2009-03-19 12:04 UTC] cweiske (Christian Weiske)
Description: ------------ I try to upgrade phpunit from 3.3.12 to 3.4.0beta1, which fails when using "pear upgrade phpunit/phpunit-beta". It fails when I use the version without "-f": "pear upgrade phpunit/phpunit-3.4.0beta1" - but it works with -f " pear upgrade -f phpunit/phpunit-3.4.0beta1". Actual result: -------------- cweiske:~/Dev/cvs/pear/pear-core> pear clear-cache reading directory /mnt/temporary/tmp/pear/cache 142 cache entries cleared cweiske:~/Dev/cvs/pear/pear-core> pear upgrade -f phpunit/phpunit-3.1.2 Did not download optional dependencies: pear/Image_GraphViz, pear/Log, use --alldeps to download automatically warning: pear/pear_info requires package "phpunit/PHPUnit" (version >= 3.1.4), downloaded version is 3.1.2 warning: pear/php_compatinfo requires package "phpunit/PHPUnit" (version >= 3.2.0), downloaded version is 3.1.2 downloading PHPUnit-3.1.2.tgz ... Starting to download PHPUnit-3.1.2.tgz (109,594 bytes) .........................done: 109,594 bytes upgrade ok: channel://pear.phpunit.de/PHPUnit-3.1.2 cweiske:~/Dev/cvs/pear/pear-core> pear upgrade phpunit/phpunit-beta Did not download optional dependencies: pear/Image_GraphViz, use --alldeps to download automatically downloading PHPUnit-3.3.15.tgz ... Starting to download PHPUnit-3.3.15.tgz (272,118 bytes) .........................................................done: 272,118 bytes upgrade ok: channel://pear.phpunit.de/PHPUnit-3.3.15 cweiske:~/Dev/cvs/pear/pear-core> pear upgrade phpunit/phpunit-3.4.0beta1 Nothing to upgrade cweiske:~/Dev/cvs/pear/pear-core> pear upgrade -f phpunit/phpunit-3.4.0beta1 Did not download optional dependencies: pear/Image_GraphViz, pear/Log, pear/Text_Diff, use --alldeps to download automatically downloading PHPUnit-3.4.0beta1.tgz ... Starting to download PHPUnit-3.4.0beta1.tgz (307,043 bytes) ...............................................................done: 307,043 bytes upgrade ok: channel://pear.phpunit.de/PHPUnit-3.4.0beta1 cweiske:~/Dev/cvs/pear/pear-core>

Comments

 [2009-03-19 12:07 UTC] cweiske (Christian Weiske)
cweiske:~/Dev/cvs/pear/pear-core> pear config-get -c phpunit preferred_state stable
 [2009-03-25 22:41 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Assigned To: +Assigned To: dufuz -Roadmap Versions: +Roadmap Versions: 1.8.0alpha2
 [2009-03-25 22:54 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Works just fine for me - see the output below, note the lack of -f in the beta1 part. I'm closing it down - please confirm and reopen if this still happens to you on the latest CVS [helgi@Stewie tests]# pear clear-cache reading directory /tmp/pear/cache 40 cache entries cleared [root@Stewie tests]# pear upgrade -f phpunit/phpunit-3.3.12 Did not download optional dependencies: pear/Image_GraphViz, pear/Log, use --alldeps to download automatically phpunit/PHPUnit can optionally use package "pear/Image_GraphViz" (version >= 1.2.1) phpunit/PHPUnit can optionally use PHP extension "pdo_mysql" downloading PHPUnit-3.3.12.tgz ... Starting to download PHPUnit-3.3.12.tgz (271,757 bytes) ............................................done: 271,757 bytes upgrade ok: channel://pear.phpunit.de/PHPUnit-3.3.12 [helgi@Stewie tests]# pear upgrade phpunit/phpunit-3.4.0beta1 Did not download optional dependencies: pear/Image_GraphViz, use --alldeps to download automatically phpunit/PHPUnit can optionally use package "pear/Image_GraphViz" (version >= 1.2.1) phpunit/PHPUnit can optionally use PHP extension "pdo_mysql" phpunit/PHPUnit can optionally use PHP extension "soap" downloading PHPUnit-3.4.0beta1.tgz ... Starting to download PHPUnit-3.4.0beta1.tgz (307,043 bytes) .....................................................done: 307,043 bytes upgrade ok: channel://pear.phpunit.de/PHPUnit-3.4.0beta1 [helgi@Stewie tests]# pear config-show | grep preferred_state Preferred Package State preferred_state stable [helgi@Stewie tests]# pear -V PEAR Version: 1.8.0alpha2 PHP Version: 5.2.8
 [2009-03-25 22:55 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Assigned +Status: Feedback
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the CVS of the package. Please log into CVS with: cvs -d :pserver:cvsread@cvs.php.net:/repository login and check out the CVS repository of this package and upgrade cvs -d :pserver:cvsread@cvs.php.net:/repository co pear-core pear upgrade pear-core/package2.xml or pear upgrade pear-core/package.xml If you are able to reproduce the bug with the latest CVS, please change the status back to "Open". Again, thank you for your continued support of PEAR.
 [2009-03-26 21:10 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Feedback +Status: Bogus -Roadmap Versions: 1.8.0alpha2 +Roadmap Versions:
Brett also confirmed that this doesn't happen anymore - You probably just had a bad checkout or not using 1.8.0 :-)
 [2009-03-27 06:40 UTC] cweiske (Christian Weiske)
Works for me with pear-1.8.0rc1