Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.21.8

Bug #16021 PHP 4 regression
Submitted: 2009-03-11 14:51 UTC Modified: 2009-03-14 21:39 UTC
From: yunosh Assigned: kguest
Status: Closed Package: Date_Holidays (version 0.21.0)
PHP Version: 4.4.9 OS:
Roadmaps: 0.21.1    
Subscription  


 [2009-03-11 14:51 UTC] yunosh (Jan Schneider)
Description: ------------ This snippet from Date_Holidays_Driver::addTranslation(): $name = get_class($this); $parts = explode("_", $name); $drivername = ucfirst($parts[3]); doesn't work on PHP 4, because get_class() returns class names all lower case in 4. Lowercasing or ucfirst() don't work here, because not all drivers work that way (UNO, USA). It's probably the safest to store the driver name in a class property.

Comments

 [2009-03-11 15:02 UTC] yunosh (Jan Schneider)
The following patch has been added/updated: Patch Name: driverName.patch URL: patch driverName.patch
 [2009-03-11 15:03 UTC] yunosh (Jan Schneider)
The patch also fixes the misspelled EasternChristian driver name.
 [2009-03-14 21:14 UTC] kguest (Ken Guest)
-Assigned To: +Assigned To: kguest
 [2009-03-14 21:39 UTC] kguest (Ken Guest)
verified...
 [2009-03-14 21:39 UTC] kguest (Ken Guest)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.