Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.1.3

Bug #15897 Sample code spews PHP notices
Submitted: 2009-02-13 14:50 UTC Modified: 2009-09-06 02:37 UTC
From: gutza Assigned: tewolde
Status: Closed Package: MDB2_TableBrowser (version 0.1.0 alpha)
PHP Version: 5.1.6 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2009-02-13 14:50 UTC] gutza (Bogdan Stancescu)
Description: ------------ Executing the advanced sample code spews out a lot of PHP notices of the form PHP Notice: call_user_method(): This function is deprecated, use the call_user_ func variety with the array(&$obj, "method") syntax instead in /usr/share/pear/M DB2/TableBrowser/Single.php on line 149 Test script: --------------- http://pear.php.net/manual/en/package.database.mdb2-tablebrowser.usage-fullexample.php Expected result: ---------------- Clean, correct execution. Actual result: -------------- Correct execution + PHP notices

Comments

 [2009-02-13 16:01 UTC] gutza (Bogdan Stancescu)
-Package Version: +Package Version: 0.1.0 alpha
Seems like the problem is indeed easily fixed by changing the calls to call_user_method() with call_user_func() in Single.php at line 149 and MultipleFliterManager.php at line 106: in both cases, I simply changed return call_user_method($method, $obj, ...) with return call_user_func(array(&$obj, $method), ...) and the code seems to run fine.
 [2009-09-02 08:46 UTC] cweiske (Christian Weiske)
-Status: Open +Status: Verified
This is indeed a bug. call_user_method needs to be replaced in Single.php
 [2009-09-06 02:37 UTC] tewolde (Isaac Tewolde)
-Status: Verified +Status: Closed -Assigned To: +Assigned To: tewolde
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/