Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0

Bug #15894 getAutoRunTemplate reads wrong path
Submitted: 2009-02-12 18:27 UTC Modified: 2009-02-15 12:50 UTC
From: ifeghali Assigned: kvz
Status: Closed Package: System_Daemon
PHP Version: 5.1.6 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2009-02-12 18:27 UTC] ifeghali (Igor Feghali)
Description: ------------ OS::getAutoRunTemplate() reads the wrong path when autoRunTemplatePath is set to false. Please see patch attached. Test script: --------------- Expected result: ---------------- Actual result: --------------

Comments

 [2009-02-12 18:31 UTC] ifeghali (Igor Feghali)
Ok i cant attach the patch. Here it goes: --- OS.php.orig 2009-02-12 16:06:37.000000000 -0200 +++ OS.php 2009-02-12 16:07:09.000000000 -0200 @@ -249,7 +249,7 @@ return false; } - return file_get_contents($this->autoRunTemplatePath); + return file_get_contents($path); }//end getAutoRunTemplate /**
 [2009-02-15 12:30 UTC] kvz (Kevin van Zonneveld)
-Assigned To: +Assigned To: kvz
 [2009-02-15 12:50 UTC] kvz (Kevin van Zonneveld)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Thanks!