Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.1

Bug #15758 URLs with # at the end not considered a url
Submitted: 2009-01-24 19:15 UTC
From: kristianly Assigned: justinpatrin
Status: Closed Package: Text_Wiki (version 1.2.0)
PHP Version: 5.2.0 OS: Linux
Roadmaps: 1.3.0    
Subscription  


 [2009-01-24 19:15 UTC] kristianly (Kristian Lyngstol)
Description: ------------ Ie: http://foo.bar.com/index.html#section1 ... I ran into this problem because my users copy-pasted a link to SomePage, also generated by Text_Wiki, which ends with a blank # (ie: http://foo.bar.com/index.php?page=MyPage#).

Comments

 [2009-06-05 22:59 UTC] rodrigosprimo (Rodrigo Sampaio Primo)
Hi kristianly, could you give more details on how to reproduce this bug? I'll be working on Text_Wiki for the next two months. I tried to reproduce the problem with # at the end of an URL by testing it here http://www.ce.unipr.it/~tomaiuol/creole_example.php I tried to convert MediaWiki syntax [http://foo.bar.com/index.html#section1] to Wiki Creole and to XHTML and both went well. Maybe I'm not understanding the problem because I'm new to Text_Wiki or maybe we need more information about it. Thanks, Rodrigo.
 [2009-06-10 01:51 UTC] rodrigosprimo (Rodrigo Sampaio Primo)
-Status: Open +Status: Feedback
Waiting feedback, as I mentioned in a previously comment I was not able to reproduce the bug.
 [2010-01-13 18:19 UTC] madmax (Max Hansen)
The problem is that the last character in the URL is restricted to be A-Z, a-z, 0-9, ?, =, & or ~. It is only the last character that has this restriction. See added patch.
 [2010-01-20 10:50 UTC] justinpatrin (Justin Patrin)
Is there a reason you removed the last bit of the regex instead of just adding # to it?
 [2010-01-20 23:57 UTC] justinpatrin (Justin Patrin)
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: justinpatrin -Roadmap Versions: +Roadmap Versions: 1.3.0
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. I've Added # to the end of the regexes for URLs across the board. I'd appreciate some testing as I'm admittedly not as close to this package as I once was.