Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.5

Bug #15309 'pubdate' invalid in RSS 1.0/1.1 feeds
Submitted: 2008-12-15 13:48 UTC Modified: 2008-12-27 05:59 UTC
From: herringm Assigned: doconnor
Status: Closed Package: XML_Feed_Parser (version 1.0.3)
PHP Version: 5.2.6 OS: RHEL 4
Roadmaps: (Not assigned)    
Subscription  


 [2008-12-15 13:48 UTC] herringm (Michael Herring)
Description: ------------ Element 'pubdate' does not exist in the RSS 1.0 or 1.1 spec, but it is supported in RSS1Element.php and RSS11Element.php. Changed this to 'date' which only exists (as the 'dc:date' element) in RSS 1.0/1.1 feeds which use the dc module. For an RSS 1.0/1.1 feed without the dc module, there can be no 'date' element and thus no publish date/time information whatsoever in the feed. This messes up date parsing for feeds with the dc:date element present.

Comments

 [2008-12-16 09:24 UTC] doconnor (Daniel O'Connor)
Hey Michael, cheers for the patch! I don't suppose you feel brave enough to do a checkout from CVS, do you? I just got unit tests into 'working' order: Tests: 1504, Assertions: 605, Failures: 464, Errors: 887, Incomplete: 11. If you wanted to apply you patch and see if it causes any regression...
 [2008-12-17 11:00 UTC] herringm (Michael Herring)
WITHOUT RSS1/1.1 PATCH* Tests: 1466, Assertions: 1011, Failures: 467, Errors: 684, Incomplete: 11. WITH PATCH* Tests: 1466, Assertions: 1011, Failures: 467, Errors: 684, Incomplete: 11. *Without these test suites in convertedtests/AllTests.php $suite->addTestSuite('amp_TestCase'); $suite->addTestSuite('atom_TestCase'); Due to a lack of memory. All tests ran using > 1GB memory_limit. It appears that skipping the deprecated tests causes major memory usage and crashes due to insufficient memory. When these tests are not skipped all of these tests error but the testing harness completes successfully.
 [2008-12-27 00:27 UTC] doconnor (Daniel O'Connor)
@ memory thing, I think I resolved that by switching off PHPUnit's backupglobals. Otherwise, hurray - no regression. I'll get around to applying it pretty soonish.
 [2008-12-27 05:59 UTC] doconnor (Daniel O'Connor)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.