Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.1

Request #14475 SelectOther as textarea instead of input text
Submitted: 2008-08-08 05:53 UTC Modified: 2008-08-10 23:59 UTC
From: mpgjunky Assigned: shangxiao
Status: Closed Package: HTML_QuickForm_altselect (version 1.0.0)
PHP Version: 5.1.6 OS: Fedora 6
Roadmaps: (Not assigned)    
Subscription  


 [2008-08-08 05:53 UTC] mpgjunky (Michael Mussulis)
Description: ------------ It would be useful if one could use a textarea tag for the "other" option instead of input type text. Perhaps it could be implemented using an option to be passed to the IncludeOther method, either true or false, or string "text" / "textarea" to indicate the tag required.

Comments

 [2008-08-09 02:06 UTC] shangxiao (David Sanders)
I've thought of adding the same thing a couple of times ;)
 [2008-08-09 02:51 UTC] shangxiao (David Sanders)
I think the string option, 'text' or 'textarea', best fits here. Thanks for the patch but I'd rather use styles in preference to tables to get the top alignment of the label. And I'd also rather still use a single parameter to setIncludeOther and test the type of it.
 [2008-08-09 05:25 UTC] shangxiao (David Sanders)
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the CVS of the package. Please log into CVS with: cvs -d :pserver:cvsread@cvs.php.net:/repository login and check out the CVS repository of this package and upgrade cvs -d :pserver:cvsread@cvs.php.net:/repository co pear/HTML_QuickForm_altselect pear upgrade pear/HTML_QuickForm_altselect/package2.xml or pear upgrade pear/HTML_QuickForm_altselect/package.xml If you are able to reproduce the bug with the latest CVS, please change the status back to "Open". Again, thank you for your continued support of PEAR. Can you verify that the committed fix is ok for you?
 [2008-08-09 05:27 UTC] shangxiao (David Sanders)
ehh... ignore the auto-comment that just got posted... Can you verify that the committed fix is ok for you?
 [2008-08-09 07:12 UTC] mpgjunky (Michael Mussulis)
Looks good :) Sorry about the table, but I was just too lazy to work out the style for the label. I prefer styles as well. Btw, could something be done regarding Validation? I tried adding a grouprule (required, min 1), but it doesn't work since the validation is checking for == '' when it should be checking for '.checked' (for checkboxes). In the end I had to ditch QF rules and implement my own using jQuery. I would prefer to use QF validation to keep it within the same code base.
 [2008-08-10 23:59 UTC] shangxiao (David Sanders)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.