Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.0a3

Bug #1445 Improvement of setTimeout() method + timout handling
Submitted: 2004-05-19 14:04 UTC Modified: 2004-06-14 15:49 UTC
From: pear dot 20 dot fab at spamgourmet dot com Assigned: toby
Status: Closed Package: Net_FTP
PHP Version: 4.3.1 OS: Win 2000
Roadmaps: (Not assigned)    
Subscription  


 [2004-05-19 14:04 UTC] pear dot 20 dot fab at spamgourmet dot com
Description: ------------ When using Net_FTP to connect to a slow or even offline ftp server, PHP will use the standard timeout of 90 seconds. This can be very annoying because the setTimeout() only works if an stream handle has already been created -> a lot of time wasted. So it would be nice to change the timeout handling a bit. I added a new private attribute (_timeout) and modified the constructor and the setTimeout() method. Regards, Nils. Reproduce code: --------------- http://www.affenkrieger.de/FTP.php

Comments

 [2004-06-14 15:49 UTC] toby
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.